Q1:怎样把通达信的DMI指标设为条件预警 通达信的条件预警没有DMI,请老师指教怎样把DMI公式设为条件...

{DMI趋向指标选股公式}
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
金叉:CROSS(PDI,MDI);

Q2:急求:帮忙把趋向指标(钱龙版本)DMI—QL,给改写成通达信中能用的公式,在次新股上能显现出正确指标...

N:=14;
M:=6;
VV:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/VV;
MDI:DMM*100/VV;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1);
ADXR:(ADX+REF(ADX,M))/2;
{已测试,复制可直接引用,如果回答满意,请记得给采纳}

Q3:通达信DMI指标谁能改成选股公式?满足以下条件:ADX大于60并且PDI小于10并且MDI大于25....

XG:DMI.ADX>60 AND DMI.PDI<10 AND DMI.MDI>25;
已测试通过!

Q4:请老师帮忙把同花顺DMI指标改写为通达信指标,谢谢

M1:=14;M2:=6;
TR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),M1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SUM(IF(HD>0 AND HD>LD,HD,0),M1);
DMM:=SUM(IF(LD>0 AND LD>HD,LD,0),M1);
DI1:DMP*100/TR1;
DI2:DMM*100/TR1;
ADX:MA(ABS(DI2-DI1)/(DI1+DI2)*100,M2);
ADXR:(ADX+REF(ADX,M2))/2;

Q5:通达信最牛最全主图指标公式怎么样

没有最牛的指标,只有最熊的指标

Q6:通达信公式,很牛的一个哦!我想找高手来改成选股公式,以堪称一绝为条件选股!求真高手

有漂移哟 小心使用 Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0);
Y1:=H=HHV(H,BARSLAST(Q_4)+1);
Y2:=HHV(H,BARSLAST(Q_4)+1);
Y3:=L=LLV(L,BARSLAST(Q_3)+1);
Y4:=LLV(L,BARSLAST(Q_3)+1);
Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0);
TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);
堪称一绝:IF(REF(TJ,1)=0 AND TJ>=1,80,10);